xmlConverter V1.8 Special Edition RELEASED

Started by Norrin Radd, July 28, 2007, 11:02AM

Previous topic - Next topic
same thing, the spaces

but i see other potential problems, thanks.

i changed the program to handle chr file types, i will try to handle the other one (nav) later

July 31, 2007, 12:26PM #17 Last Edit: July 31, 2007, 12:42PM by Norrin Radd
@ Teancum, can you show me how the NAV file ends in xml1 format please, also in the xml2 file also.

thanks, i'll try to add that one when i have time

XML1 NAV (shortened)
<nav cellSize="40">
    <c p="22 56 0" />
    <c p="23 56 0" />
    <c p="22 55 0" />
    <c p="23 55 0" />
    <c p="22 54 0" />
    <c p="23 54 0" />
    <c p="19 52 0" />
    <c p="20 52 0" />
    <c p="62 90 0" />
    <c p="61 90 0" />
    <c p="60 90 0" />
    <c p="59 89 0" />
    <c p="59 88 0" />
    <c p="59 87 0" />
    <c p="59 86 0" />
    <c p="50 77 144" />
    <c p="51 77 144" />

XML2 NAVB (shortened)
XMLB nav {
cellsize = 40 ;
   c {
   p = 27 62 0 ;

   c {
   p = 16 78 0 ;

   c {
   p = 17 78 0 ;

   c {
   p = 4 74 0 ;

   c {
   p = 3 74 0 ;


nav file type supported, thanks for the examples Teancum

It keeps telling me that it cannot find the file I am trying to convert. Now, I'm an idiot, so this is probably something dumb on my part, but any ideas why this might be the case?

can you tell me what you type in at the command line, which directory you are in when you call the function, and where the files are located.

I type "xmlConverter.exe -eng ps_avalanche.eng ps_avalanche.eng"

I am in a folder on my Desktop (which means there ARE spaces from "Documents and Settings, don't know if that is the problem)

xmlConverter.exe is in C:/Windows.

why do you call the input and output files the same name?

what version are you using?
type "xmlConverter.exe" to find out


It is still telling me "could not open file".

when you type "xmlConverter.exe" it is telling you it could not open the file?

didnt another version work for you?, its weird that this one wouldnt. sorry to ask but could you try version 1.2, or even 1.0 (just omit -eng for 1.0)

"Abnormal Program Termination" with 1.0.

August 01, 2007, 12:25PM #28 Last Edit: August 01, 2007, 12:28PM by Norrin Radd
@blizz its because you are using THE SAME file for input and output. (for the abnormal termination part anyway)
thats a nono.
your input file is erased when you open to read it.

so its not a problem with the program. 

i did what you did and got the same errors, but i tried a new file, using a DIFFERENT output file, and it worked, so let me know if it works for you.

Now it is saying "ERROR:Could not open file."

To be clear: I have the folder with the file open, I run the command prompt, I type in the line (with the different XML1 and XML2 file names), and the error pops up. :banghead: